Détails du package smp-disable-ipv6_1.0-5_all.wapt
retour Revenir à la liste des packages

smp-disable-ipv6

ATTENTION CE DÉPÔT n'est plus compatible 1.3 vous devez migrer en 1.5.1.21 !

Fichier control :

package           : smp-disable-ipv6
version           : 1.0-5
architecture      : all
section           : base
priority          : optional
maintainer        : TIS <technique@tranquil-it-systems.fr>
description       : disable ipv6 (except loopback interface)
depends           : 
conflicts         : 
maturity          : 
locale            : 
min_os_version    : 
max_os_version    : 
min_wapt_version  : 
sources           : 
installed_size    : 
signer            : wapt.lesfourmisduweb.org
signer_fingerprint: 8da83ebdac1a25e820b186510d049f47407b11835b0664fdc5bacd3595b1671d
signature         : zcf1lKACmmKm/GwOV/9l5s79lquVZnv4b4iJAEkhKcA8sUYnTwawJ5nmZ3uLV3qZe/LV3B4v/D8x/hf2zB1w0G7/dEHQoz6AXDnUHNxSNJ7Tv2CayX0mlJahSEqNILgZ+lVg0PLIj/DUp88Fr4DB8Fpj4IdmKz11sCSwmchdGf7DTx32O06+9+cWmcjFmgUki1PkBkoKumthe8hn2G/JBnuno9p5EhMGo1FJwxnvKf0h8xcWresfLI+fWL4BXzE36/TkPLQ74D5guisvoVuPUjK/2GxkEXHAVkh6mSQVWjgdPYNJZLPV6GwdgUNRJTaUH87BmLobNvo9//zOtkOpGA==
signature_date    : 20171122-013509
signed_attributes : package,version,architecture,section,priority,maintainer,description,depends,conflicts,maturity,locale,min_os_version,max_os_version,min_wapt_version,sources,installed_size,signer,signer_fingerprint,signature_date,signed_attributes






Fichier setup.py :

# -*- coding: utf-8 -*-
from setuphelpers import *

uninstallkey=[]

def install():
    registry_setstring(HKEY_LOCAL_MACHINE,r'SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters','DisabledComponents',0xff,type=REG_DWORD)

    if windows_version() >= Version('6.0.0'):
        run('netsh interface teredo set state disabled ')
        run('netsh interface ipv6 6to4 set state state=disabled undoonstop=disabled')
        run('netsh interface ipv6 isatap set state state=disabled')