Détails du package smp-dotnetfx4.5_4.5.51209.34209-6_all.wapt
retour Revenir à la liste des packages

smp-dotnetfx4.5

ATTENTION CE DÉPÔT n'est plus compatible 1.3 vous devez migrer en 1.5.1.21 !

Fichier control :

package           : smp-dotnetfx4.5
version           : 4.5.51209.34209-6
architecture      : all
section           : base
priority          : optional
maintainer        : aiz <sfonteneau@stemarie-aizenay.fr>
description       : Dot net Framework CLient
depends           : smp-dotnetfx4.0
conflicts         : 
maturity          : 
locale            : 
min_os_version    : 
max_os_version    : 
min_wapt_version  : 
sources           : 
installed_size    : 
signer            : wapt.lesfourmisduweb.org
signer_fingerprint: 8da83ebdac1a25e820b186510d049f47407b11835b0664fdc5bacd3595b1671d
signature         : MqaE7a3PQWqOrr7xbPXYxcl42SCblMcJc0CjwUrFYyTletDurEut37wYbmkGH6IU9WXG8mp2GgTwyreJq1V0XI8gqKop7HFdUtrZ9I+IjyRxfY2e31zHzMXBE8F9oPtLp1PqdOgLwdF9EbmR6lis/SztQy0AyoAksVRdTJ4J1rV9E92GYwuS6ISbVSpzyreiGrp+0HQKjVV3katcDGbVN8aXLEXQHjmvvFpWl+PLxeNem49tvU/FSE8i3K52UcxZGT8A7fESQ167fscB4bURqJorJygB4ul4vVC4R7f41bq6Akkzh8WnOsezceOVC+80Fkgex7dUjCHYmmIJjGy/jg==
signature_date    : 20171122-013519
signed_attributes : package,version,architecture,section,priority,maintainer,description,depends,conflicts,maturity,locale,min_os_version,max_os_version,min_wapt_version,sources,installed_size,signer,signer_fingerprint,signature_date,signed_attributes






Fichier setup.py :

from setuphelpers import *
from subprocess import CalledProcessError

uninstallkey=[]
uninstallstring=[]

def install():
    print("installing Dot Net fx 4.5")
    try:
        run("NDP452-KB2901907-x86-x64-AllOS-ENU.exe /q /norestart")
    except CalledProcessError,e:
        # must be restarted
        if e.returncode<>3010:
            raise

    print("After install, restarting your computer is recommended.")