Détails du package smp-dotnetfx4.0_4.0-6_all.wapt
retour Revenir à la liste des packages

smp-dotnetfx4.0

ATTENTION CE DÉPÔT n'est plus compatible 1.3 vous devez migrer en 1.5.1.21 !

Fichier control :

package           : smp-dotnetfx4.0
version           : 4.0-6
architecture      : all
section           : base
priority          : optional
maintainer        : TIS <technique@tranquil-it-systems.fr>
description       : Dot net Framework CLient
depends           : 
conflicts         : 
maturity          : 
locale            : 
min_os_version    : 
max_os_version    : 
min_wapt_version  : 
sources           : 
installed_size    : 
signer            : wapt.lesfourmisduweb.org
signer_fingerprint: 8da83ebdac1a25e820b186510d049f47407b11835b0664fdc5bacd3595b1671d
signature         : n+wEHOpR7cgbF+I72IEdguXJw2tQ8wj5bT9m1XuRzCVbiTyVndQt5pFugQ5PdelMVjOESfPQZRqH6L/dxzRHEf/afa+V6UX4z1JvIhyl+nx4LruQqbKZrCNSTVpRoKuFAEGjylvIP2aNnetCUVOW+1MWl7Tr3B4XYe7aoRaeaJjfV//r3UCgN0WUcGq14WWAE/jKmk705R+FP3khihKfH0rbYKcUVZ4Af6WR/ScdH39Zr4hgGW+FmBap6wnjLvZt862XnPof5gn7ZMTLYsKhdi2ERt/UYEEXGC3jNnAO04QqfxsJHKld57Q0pMmHn+lwFVjA2kYUL4FS2h20ZHrhKw==
signature_date    : 20171122-013517
signed_attributes : package,version,architecture,section,priority,maintainer,description,depends,conflicts,maturity,locale,min_os_version,max_os_version,min_wapt_version,sources,installed_size,signer,signer_fingerprint,signature_date,signed_attributes






Fichier setup.py :

from setuphelpers import *
from subprocess import CalledProcessError

uninstallkey=[]
uninstallstring=[]

def install():
    print("installing Dot Net fx 4.0")
    try:
        run("dotNetFx40_Full_x86_x64.exe /q /norestart",timeout=1800)
    except CalledProcessError,e:
        # must be restarted
        if e.returncode<>3010:
            raise

    print("After install, restarting your computer is recommended.")