Détails du package smp-opensankore_2.5.1-1_all.wapt
retour Revenir à la liste des packages

smp-opensankore

ATTENTION CE DÉPÔT n'est plus compatible 1.3 vous devez migrer en 1.5.1.21 !

Fichier control :

package           : smp-opensankore
version           : 2.5.1-1
architecture      : all
section           : base
priority          : optional
maintainer        : Lesfourmisduweb
description       : Open-Sankoré offre de nombreux outils interactifs pour créer et animer des présentations numériques pour vos cours.
depends           : 
conflicts         : 
maturity          : 
locale            : 
min_os_version    : 
max_os_version    : 
min_wapt_version  : 
sources           : http://open-sankore.org/fr/
installed_size    : 
signer            : wapt.lesfourmisduweb.org
signer_fingerprint: 8da83ebdac1a25e820b186510d049f47407b11835b0664fdc5bacd3595b1671d
signature         : EFcuyifLMgCeV9DgJoU+XJhc+Ylo5uhqdrKnmPBuDlrvtU8LdTOFHPOIlLl9iR/lUvB0U9l+YC/rdvIBaOjgZhptVCWzS3EozLTkhWl1Bh2Ofo/RSwUnhlMIB0ETscY0xEZFldn1X/IHjbF/9/iw1NWk+uobFmRvPhSYiF/WDWQfgl7eSXixjRFlQ4NadQ7Tx2Hj5VZOMn0sv3H7NbVMZDBFI7smtt8TDrliQyERLpFXVNqgzwhbDtypTGaoLYgaOAZA8BV66FvKJL3ouUG/Ike6g5xsnM3gpLxNCm6MhxXTOmVrkTkM3mr77S7Nbv8IIXmuxWGH42CQkfn5DUMeug==
signature_date    : 20171122-013653
signed_attributes : package,version,architecture,section,priority,maintainer,description,depends,conflicts,maturity,locale,min_os_version,max_os_version,min_wapt_version,sources,installed_size,signer,signer_fingerprint,signature_date,signed_attributes






Fichier setup.py :

# -*- coding: utf-8 -*-
from setuphelpers import *
import os.path

# registry key(s) where WAPT will find how to remove the application(s)
uninstallkey = []

# command(s) to launch to remove the application(s)
uninstallstring = []

# list of required parameters names (string) which can be used during install
required_params = []

def install():
    # if you want to modify the keys depending on environment (win32/win64... params..)
    global uninstallkey
    global uninstallstring

    softname = 'Open-Sankor'
    versionsoft = '2.5.240.1'

    check_installed = installed_softwares(softname)
    # si cette liste globale n est pas vide, on check chaque logiciel
    if check_installed:
            # boucle pour chaque logiciel trouvée
        if os.path.isfile(makepath(programfiles32,'Open-Sankore','Open-Sankore.exe')):
           exefilename = makepath(programfiles32,'Open-Sankore','Open-Sankore.exe')
           versionexe = get_file_properties(exefilename)['FileVersion']
           if versionexe == versionsoft:
                        print(u'The software installation was successful')
                        return (0);
           if versionexe > versionsoft:
                        print(u'The software is already installed and its version is newer than the version of the package' )
                        return (0);

    print('installing opensankore')
    run(r'"Open-Sankore.exe" /VERYSILENT')



    check_installed = installed_softwares(softname)
    # si cette liste globale n est pas vide, on check chaque logiciel
    if check_installed:
            # boucle pour chaque logiciel trouvée
        if os.path.isfile(makepath(programfiles32,'Open-Sankore','Open-Sankore.exe')):
           exefilename = makepath(programfiles32,'Open-Sankore','Open-Sankore.exe')
           versionexe = get_file_properties(exefilename)['FileVersion']
           if versionexe == versionsoft:
                        print(u'The software installation was successful')
                        return (0);
           if versionexe > versionsoft:
                        print(u'The software is already installed and its version is newer than the version of the package' )
                        return (0);
           if versionexe != versionsoft:
                        error('The output verification has found a old version of software')
    error('End audit did not find the software.')